Performance degradation affecting Uganda Airtel services
Incident Report for pawaPay
Resolved
This incident has been resolved.
Posted Jul 22, 2024 - 01:10 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 21, 2024 - 21:34 UTC
Investigating
We are experiencing an outage of the Uganda Airtel services. We are investigating the issue.
Posted Jul 21, 2024 - 21:08 UTC
This incident affected: Uganda MNO services (Airtel :: Web Deposit, Airtel :: USSD Deposit, Airtel :: Payout).