Performance degradation affecting SV Benin MTN services
Incident Report for pawaPay
Resolved
This incident has been resolved.
Posted Jul 27, 2024 - 00:25 UTC
Investigating
We are experiencing degraded performance in the SV Benin MTN services. We are investigating the issue.
Posted Jul 26, 2024 - 17:20 UTC
This incident affected: Benin MNO services (MTN :: Web Deposit, MTN :: Payout).