Performance degradation affecting Tanzania Halotel services
Incident Report for pawaPay
Resolved
This incident has been resolved.
Posted Jul 25, 2024 - 20:42 UTC
Investigating
We are experiencing degraded performance in the Tanzania Halotel services. We are investigating the issue.
Posted Jul 25, 2024 - 18:17 UTC
This incident affected: Tanzania MNO services (Halotel :: Web Deposit).