Performance degradation affecting Uganda MTN services
Incident Report for pawaPay
Resolved
This incident has been resolved.
Posted Jul 25, 2024 - 20:42 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 25, 2024 - 17:44 UTC
Investigating
We are experiencing an outage of the Uganda MTN services. We are investigating the issue.
Posted Jul 25, 2024 - 16:39 UTC
This incident affected: Uganda MNO services (MTN :: Web Deposit, MTN :: USSD Deposit, MTN :: Payout).