Performance degradation affecting Zambia Zamtel services
Incident Report for pawaPay
Resolved
The incident has been resolved. We apologise for the inconvenience.
Posted Feb 13, 2024 - 08:31 UTC
Identified
We have identified instability in Zambia Zamtel services. We have escalated this to the MNO for resolution.
Posted Feb 13, 2024 - 05:53 UTC
This incident affected: Zambia MNO services (Zamtel :: Web Deposit, Zamtel :: Payout).