Performance degradation affecting Tanzania Halotel services
Incident Report for pawaPay
Resolved
This incident has been resolved.
Posted Jul 27, 2024 - 00:26 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 26, 2024 - 20:32 UTC
Investigating
We are experiencing degraded performance in the Tanzania Halotel services. We are investigating the issue.
Posted Jul 26, 2024 - 17:31 UTC
This incident affected: Tanzania MNO services (Halotel :: Web Deposit).