Performance degradation affecting Tanzania Halotel services
Incident Report for pawaPay
Resolved
The incident has been resolved. We apologise for the inconvenience.
Posted Jul 18, 2024 - 13:38 UTC
Monitoring
We are seeing improvements in success rates and will continue monitoring the incident.
Posted Jul 18, 2024 - 11:31 UTC
Identified
We have identified instability in Tanzania Halotel services. We have escalated this to the MNO for resolution.
Posted Jul 18, 2024 - 11:09 UTC
This incident affected: Tanzania MNO services (Halotel :: Web Deposit, Halotel :: USSD Deposit, Halotel :: Payout).