Performance degradation affecting Kenya M-Pesa services
Incident Report for pawaPay
Resolved
The incident has been resolved. We apologise for the inconvenience.
Posted Jul 17, 2024 - 15:10 UTC
Monitoring
A fix has been deployed by Kenya M-Pesa. We are seeing improvements in success rates and will continue monitoring the incident.
Posted Jul 17, 2024 - 13:39 UTC
Identified
We have identified instability in Kenya M-Pesa services. We have escalated this to the MNO for resolution.
Posted Jul 17, 2024 - 13:07 UTC
This incident affected: Kenya MNO services (M-Pesa :: Web Deposit, M-Pesa :: USSD Deposit, M-Pesa :: Payout).